
Microsoft FrontPage 
 

 

1. Introduction 
 

Microsoft FrontPage is a full featured HTML editor. A Web site is a group of HTML 

pages and graphics that are interconnected with hyperlinks. A FrontPage Web site is a site 

created in FrontPage. It contains Web pages graphics, documents, multimedia. 

 

FrontPage 2000 includes the FrontPage Explorer, where you create, design, and manage 

your entire Web site, and the FrontPage Editor, where you create and edit Web pages 

without needing to know Hypertext Markup Language (HTML). FrontPage includes many 

features that make Web-site creation easy for any user, such as a gallery of professionally 

designed graphical themes, a full set of wizards and templates for creating pages and 

FrontPage webs, active page elements for providing complex functionality without 

programming, and a Tasks list for tracking tasks as you create your FrontPage web. 

You use the FrontPage Explorer to create the structure or layout of your Web site, apply 

graphical themes to its pages, organize its files and folders, import and export files, test 

and repair hyperlinks, administer access privileges, track tasks, and launch the FrontPage 

Editor to design and edit the contents of your Web pages. When your FrontPage web is 

completed, you use the FrontPage Explorer to publish it on your computer, your 

organization’s intranet, or the World Wide Web. 

You use the FrontPage Editor to create, design, and edit World Wide Web pages. As you 

add text, images, tables, form fields, and other elements to your page, the FrontPage Editor 

displays them as they would appear in a Web browser. Although it is a powerful tool, the 

FrontPage Editor is easy to use because of its familiar, word-processor interface. You do 

not need to learn hypertext markup language (HTML) to use the FrontPage Editor because 

it creates all the HTML code for you. 

If you want to edit HTML code directly, you can using the FrontPage Editor’s HTML 

view. In this view, you can enter text; edit HTML tags or script code, and use standard 

word-processing commands such as cutting, pasting, finding, and replacing. 

FrontPage is a member of the Microsoft Office family of products, and shares many of the 

features of Microsoft Word and Microsoft Excel, such as the Microsoft Clip Gallery, 

global spell checking and thesaurus, and easy table-editing. FrontPage 2000 also manages 

hyperlinks created in Microsoft Office  documents. 

1.1 Starting Microsoft FrontPage 

Click Start button ->Programs->Microsoft FrontPage,  

 

 



Microsoft FrontPage 

 

Training Programme under CAFT “Online Content Creation and Management in an eLearning Environment” 

126 

 

 
 

1.2 Using the Views Bar 

In FrontPage there are 3 views.     This menu bar is located in the 

bottom left corner of the page. 

1.  Normal tab to edit a webpage. 

2.  HTML tab to edit the HTML source code for the page. 

3.  Preview Shows what your documents appearance will be in a browser 

  

 

1.3 To create and save a new page:  

1) Open FrontPage 2000. A blank page appears in Page View.  

2) Click the Normal tab at the bottom of the page.  

3) Place the cursor inside the blank page and type a title or a few lines of text.  

4) Click File on the Menu bar, then select Save. The Save As dialog box appears.  
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5) In the Save As dialog box, click the Change button to change the title of your 

page. The Set Page Title dialog box appears.  

6) Type a new name into the Set Page Title dialog box and click OK.  

 

7) In the Save As dialog box, choose a file name and type it into the File name text 

box.  

 

8) Click the Save button.  

1.4 To change the background color of your Web page: 

 

1) Click Format on the Menu bar and select Background. The Page Properties dialog 

box appears. 

2) Click the Background tab. 

3) Click the Colors Background drop-down box and select a color. 
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4) Click OK on the Page Properties dialog box 

1.5 Set a background picture for a page 

You can set a background picture for a page. All page elements, such as text and graphics, 

will appear on top of the background picture. You can use pictures from a web, a file 

system, the World Wide Web, or clip art. You can also set the background picture to be a 

watermark, which means the picture that does not scroll as the page scrolls. However, not 

all Web browsers support watermarks. 

Note   If the page uses a theme, modify the background picture by changing the graphics 

used in the theme.  

1. In Page view, right-click the page, and then click Page Properties on the shortcut 

menu.  

2. Click the Background tab.  

3. Select the Background picture check box, and then click Browse.  

4. Select the background picture:  

o If the picture is in a web, browse to the web and folder that contains the 

picture, select the picture you want, and then click OK.  

o If the picture is on your local network, click File , browse to the picture 

you want from your local network, and then click OK.  

o If the picture is on the World Wide Web, click World Wide Web . In 

your Web browser, browse to the picture that you want, and then switch 

back to Microsoft FrontPage. The location of the page you visited will be 

displayed in the URL box. Click OK.  

o If the picture is clip art, click Clip Art to display the Microsoft Clip 

Gallery, right-click the picture that you want, and then click Insert on the 

shortcut menu.  

1.6 To add text to your Web page: 

 

1) If you are not in Page View, click the Page button on the Views bar. 

2) Click the Normal tab at the bottom of the page. 

3) Insert the cursor into the blank page. 

4) Type your text. 

You can make the text bold, italic, underlined, left justified or right justified. 

Just select the text with your mouse, then click the appropriate button on the Format 

mk:@MSITStore:C:/Program%20Files/Microsoft%20Office/Office/1033/frontpg.chm::/THM005_change_graphics.htm
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toolbar. 

Once you've put text on your page, you can change its style, color, size, and more. 

1.6.1 To change the font style: 
 

1) Select the text. 

2) Click the arrow button next to the Font display. A drop-down list appears with 

various font styles. 

3) Click the font style of your choice. 

 

1.6.2 To change the text color: 
 

1) Select the text. 

2) Click the arrow button next to the Font Color button. A Color menu appears. 

3) Click the color of your choice from the Standard Color palette. Or, select from a 

larger color palette by clicking More Colors. 
 

1.6.3 To change the font size: 
 

1) Select the text. 

2) Click the arrow button next to the Font Size display. A drop-down list appears 

with various font sizes. 

3) Click the font size of your choice. 

 

 
 

Fig.1. Changing FONT 
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1.7 Add borders around text: 

You can add borders around text, and then set properties, such as the style, color, padding, 

and width of the border.  

For example, the style of the border around this paragraph is double, and the color blue.  

When you add a border, it is applied to an entire paragraph. For example, if you apply a 

border to a selected word, the border is applied to the whole paragraph. Or, if you select 

two paragraphs and then apply a border, each paragraph will have a border around it. If 

text is separated by line breaks rather than paragraph marks, the text is considered to be 

one paragraph and will have one border.  

1. In Page view, select the paragraphs around which you want to add a border.  

2. On the Format menu, click Borders and Shading.  

3. Do one of the following:  

o If you want a four-sided border, under Setting, click Box. Set properties for 

the border by clicking options from Style, Color, and Width.  

o To create a custom border, under Setting, click Custom. A custom border 

can have borders on particular sides, and each side can have a different 

style, color and width. From the Style box, click a border style. You can 

also click options from Color and Width. Under Preview, apply the border 

to one or more sides by clicking the diagram's sides or by clicking the 

buttons.  

4. To specify the padding (the distance between the text and its border), under 

Padding, enter a value in the Top, Bottom, Left, and Right boxes in points.  

1.8 Add shading to text: 

You can add shading to text. Shading, like a page background, can be a color or a picture.  

For example, you can add shading to highlight a paragraph as shown here. 

When you add shading, it is applied to an entire paragraph. For example, if you apply 

shading to a selected word, the entire paragraph will be shaded. Text separated by line 

breaks rather than paragraph marks is considered to be one paragraph.  

1. In Page view, select the paragraphs to which you want to add shading.  

2. On the Format menu, click Borders and Shading, and then click the Shading 

tab.  

3. To set a background color for the selected text, select a color in the Background 

color box.  

4. To set the color of the selected text, select a color in the Foreground color box.  

5. To set a background picture for the selected text, type the picture name and 

location in the Background picture box, or click Browse to find and select the 

picture.  
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Set the properties for the background picture:  

o  To specify the vertical and horizontal position of the picture within the selected 

paragraph, click options from the Vertical position and Horizontal position 

boxes.  

o  In the Repeat box, click an option to specify how you want to tile the picture 

under the selected text. For example, to tile the picture horizontally, click Repeat-

x.  

o  In the Attachment box, click an option to specify whether the background picture 

should be fixed relative to the browser window, or whether it should scroll with 

the document.  

 
1.9 Add a marquee 

 

1. In Page view, at the bottom of the document window, click Design . 

2. Click where you want to add the marquee, and then type and select that text. 

3. On the Insert menu, click Web Component. 

4. Under Component type, click Dynamic Effects. 

5. Under Choose an effect, double-click Marquee. 

6. Set the properties that you want for the marquee, and then click OK. 

1.10 Set the text alignment: 

You can align text to the left, right, or center of the page. The alignment setting affects all 

text in the paragraph.  

1. In Page view, select the text you want to align.  

2. Click Align Left, Center, or Align Right to align the text.  

Tip   You can change a style (such as the Normal style) with your alignment settings so 

that you only need to set your preferences once. Then, just apply the style to new text, and 

your alignment settings will be applied automatically. 

1.11 Create a bulleted list 

To display a non-sequential list of items, create a bulleted list. Following is an example of 

a bulleted list:  

 Apples  

 Bananas  

 Oranges  

1. In Page view, position the insertion point where you want to create a list.  

2. On the Format menu, click Bullets and Numbering.  

3. Do one of the following:  

o To use standard bullets such as circles or squares, click the Plain Bullets 

tab, click the box with the bullets you want to use, and then click OK.  
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o To use custom bullets, click the Picture Bullets tab, and click Specify 

picture. Click Browse to find and select the graphic you want to use. Click 

OK.  

o To use bullets from the current theme (if the page uses a theme), click the 

Picture Bullets tab, and then click Use pictures from current theme.  

4. For each item you want to add to the list, type the item and then press ENTER. 

When you have typed the last item, press ENTER twice to end the list.  

Tip   To quickly create a bulleted list, click Bullets , and then type the items. Or, to add 

bullets to a group of items, select the items, and then click Bullets . The default bullet 

style is used. If the page uses a theme, bullets from the theme are used. 

1.12 Create a numbered list 

To display a sequential list of items, create a numbered list. The following procedure is an 

example of a numbered list.  

1. In Page view, position the insertion point where you want to create a list.  

2. On the Format menu, click Bullets and Numbering, and then click the Numbers 

tab.  

3. Click the box with the style of numbers you want to use, and then click OK.  

4. For each item you want to add to the list, type the item and then press ENTER. 

When you have typed the last item, press ENTER twice to end the list.  

1.13 Create a definition list 

You can display definitions and terms in a definition list format. Generally, the term is 

positioned flush left, and its definition is indented. The exact formatting of the list depends 

on the Web browser being used. Following is an example of a definition list:  

Term A  

This is the definition for Term A.  

Term B  

This is the definition for Term B.  

You can also add formatting as needed; for example, you can make terms bold.  

1. In Page view, position the insertion point where you want to create a list.  

2. In the Style box, click Defined Term, type the first term in the list, and then press 

ENTER.  

The next line is automatically formatted with the Definition style. 

3. Type the term's definition, and then press ENTER.  

Or, to add a second paragraph to the definition, press CTRL+ENTER. A line break 

is used to separate the paragraphs. Press ENTER to continue to the next term. 

The next line is automatically formatted with the Defined Term style. 

Repeat steps 2 and 3 for each term and definition. 

4. To end the list, press ENTER twice.  
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1.14 Horizontal Lines 

Horizontal lines can divide sections of text for easy reading. Place the cursor on the page 

where the horizontal line should be added. 

Select Insert|Horizontal Line from the menu bar. 

Double click on the line to change its properties. 

Set the Width of the line either as a percentage of the window or an absolute size in 

pixels. 

Change the thickness of the line by setting the Height in pixels. 

Set the Alignment of the line to the left, center, or right size of the page. 

The lines are automatically shaded to give the illusion of depth. Check the Solid line box 

to make the line all one color and set a Color for the line if necessary (not supported by 

Netscape). 

Shaded horizontal line: 

Click OK when finished. 

 

2. Current web browsers support two different image types, GIF and JPEG.  

GIF (Graphic Interchange Format) -- A 

common format for image files, especially 

suitable for images containing large areas of the 

same color. GIF format files of simple images 

are often smaller than the same file would be if 

stored in JPEG format, but GIF format does not 

store photographic images as well as JPEG. 
 

JPEG or JPG ( Joint Photographic Experts 

Group) --File format for full-color and black-

and-white graphic images. JPEG images allow 

for more colors than GIF images but are usually 

larger in size.  

 

To add a clip art image to your Web site: 

 

1) Place the cursor on the page. 

2) Click Insert on the Menu bar and select Picture, then Clip Art. The Clip Art Gallery 

dialog box appears. 

3) Click the Pictures tab. A group of picture categories appears. 

4) Click the category of your choice. A group of pictures appears. 

5) Click the picture you want to add. A drop-down list of buttons appears. 

6) Click the Insert Clip button. 
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2.1 To add alternative text to an image: 

 

1) Place the pointer on the image and right-click your mouse button. A pop-up menu 

appears. 

2) Click on Picture Properties. The Picture Properties dialog box appears. 

3) Click the General tab. 

4) Type the alternative text into the Alternative Representations text box. 

5) Click OK in the Picture Properties dialog box. 

 

2.2 To move an image from one location to another: 

 

1) Click the image to select it. 

3) Click the Cut button on the Standard toolbar. The image disappears. 

3) Place the cursor where you want the image to go. Note: You can place the image 

on the same page you cut it from or on a different one. 

4) Click the Paste button on the Standard toolbar. The image reappears in its new 

location. 

 

TIP: You can also use the "drag and drop" method to move an image to a different spot on 

the same Web page. Just click on the image and hold down your mouse button. Drag the 

image to a different spot, then release your mouse button to drop the image into place. 

 

3. HYPERLINKS 

 

Hyperlinks are text or graphics that can be clicked to bring the user to another web file 

such as a web page or graphic. They are the essence of the World Wide Web as they link 

pages within sites and web sites to other web sites.  

 

Hyperlinks are like springboards that send you: 

 

· to another location on the same Web page (great for really long scrolling pages!) 

· to a different page in your site 

· to a different Web site. 

 

3.1 To make text into a hyperlink: 

 

1) Select the text. 

2) Click the Hyperlink button on the Standard toolbar. The Create Hyperlink dialog 

box appears. 

3) Find and click the file name of the page you want to link to. The file name 

appears in the URL text box. If you are linking to another Web site, type the URL 

(Web address) into the URL text box. 

4) Click OK in the Create Hyperlink dialog box. 
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3.2 To make an image into a hyperlink: 

 

1) Select the picture by clicking on it. 

2) Click the Hyperlink button on the Standard toolbar. The Create Hyperlink dialog 

box appears. 

3) Find and click the file name of the page you want to link to. The file name 

appears in the URL box. 

4) Click OK in the Create Hyperlink dialog box. 

 

3.3 To create an e-mail hyperlink: 

 

1) Select the text or image. 

2) Click the Hyperlink button on the Standard toolbar. The Create Hyperlink dialog 

box appears. 

3) Click the Make a Hyperlink that Sends E-mail button. 

4) Type your e-mail address into the Type an E-mail address text box, then click OK. 

5) Click OK in the Create Hyperlink dialog box. 

There are six different ways to look at your Web site in FrontPage 2000. You can 

change views by using the View bar. 

 

3.4 Bookmarks 

 

Text and graphics can be set as bookmarks (called "anchors" everywhere except 

FrontPage) that can be linked to within a page. For example, if a page lists a course 

syllabus, the titles for each week can be set as bookmarks and a row of links can be added 

to the top of the page that will each skip down to those bookmarked sections. This method 

of using bookmarks allows visitors to your site to quickly access information by not 

having to scroll down the page to view the information they want. 

 

3.4.1 Add a bookmark to a page by following these steps highlighting the text or graphic 

that will be the bookmark and select Insert|Bookmark... from the menu bar. Enter the 

bookmark name in the space provided and click OK. 

 

3.4.2 Create a link to a bookmark by highlighting the text that will be the link and 

pressing CTRL+K. Select the bookmark from the drop-down menu in the Optional 

category and click OK. Link to a bookmark on a separate page by first selecting the file 

name from the listing and then choosing from the bookmarks in the drop-down menu. 
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3.5 Create a frames page  

A frames page is a special kind of HTML page that divides the browser window into 

different areas called frames, each of which can display a different page. When you click a 

hyperlink on a page displayed in one frame, the page pointed to by that hyperlink can be 

displayed in another frame. 

The frames page itself contains no visible content: It's just a container that specifies which 

other pages to display and how to display them. 

When you create a frames page using one of the frames page templates in FrontPage, the 

navigation between frames is already set up for you. In the Contents frames page template, 

for example, clicking a hyperlink in the Contents frame on the left displays a page in the 

Main frame (called the target frame) on the right.  

1. On the File menu, point to New, click Page, and then click the Frames Pages tab.  

2. Click a frames page template.  
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3.6 Horizontal Lines 

 

Horizontal lines can divide sections of text for easy reading. 

Place the cursor on the page where the horizontal line should be added. 

Select Insert|Horizontal Line from the menu bar. 

Double click on the line to change its properties. 

Set the Width of the line either as a percentage of the window or an absolute 

size in pixels. 

Change the thickness of the line by setting the Height in pixels. 

Set the Alignment of the line to the left, center, or right size of the page. 

The lines are automatically shaded to give the illusion of depth. Check the 

Solid line box to make the line all one color and set a Color for the line if 

necessary (not supported by Netscape). 

Shaded horizontal line: 

___________________________________________________________________ 

Click OK when finished. 

3.7 Create a table and set its properties 

When you create a table, you can also specify its properties, such as the number of rows 

and columns, its size and alignment, border attributes, and so on.  

1. In Page view, position the insertion point where you want to insert the table.  

2. On the Table menu, point to Insert, and then click Table.  

3. In the Rows box, enter the number of rows you want.  

4. In the Columns box, enter the number of columns you want.  

5. In the Alignment box, select the position for the table on the page.  

6. In the Border size box, enter the width you want for the table border in pixels. If 

you do not want a border, type 0.  

7. To change the table's cell padding (the space between a cell's border and content), 

enter a number in the Cell padding box.  

8. To change the table's cell spacing (the space between cells), enter a number in the 

Cell spacing box.  

9. To change the table's width, do one of the following:  

o Select In pixels, then type the width you want the table to be in pixels.  

o Select In percent, then type a percentage of the screen width you want the 

table to be. If the table is to appear in a frame, specify a percentage of the 

frame width.  

Note   The properties that you specify for the new table will be used as the default 

properties the next time you create a table.  
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3.8 Format headings in a table 

To emphasize certain cells in your table, such as the first row or column, you can format 

the cells as table headers. By default, table headers appear in bold. However, you can 

modify the table header style (th) and define additional properties for your table headers, 

such as shading. 

  Jan Feb Total 

East       

West       

Total       

1. In Page view, select the cell, row, or column you want to format as a header.  

2. Right-click, and then click Cell Properties on the shortcut menu.  

3. Select the Header cell check box 

3.8.1 Insert a table caption 

You can add a caption — a title — to a table to label it or summarize its content for a site 

visitor. A table caption can be displayed above or below the table. You can also align the 

caption and format it like you would any other text.  

1. In Page view, position the insertion point in the table.  

2. On the Table menu, point to Insert, and then click Caption.  

3. Type the text for your caption.  

Tips  

 To position the caption below the table, right-click the caption, and then click 

Caption Properties on the shortcut menu. Click Bottom of table, and then click 

OK.  

 To change the alignment of the caption, select the caption, and then click Align 

Right or Align Left on the Formatting toolbar 

3.9 Merge cells 

You can combine two or more adjacent cells to make a larger cell by merging them.  

      

        

Note   This command is only available when two or more adjacent cells are selected, and 

the selected cells form a rectangle.  

 In Page view, select a row, column, or a group of adjacent cells, right-click the 

selection, and then click Merge Cells on the shortcut menu.  

mk:@MSITStore:C:/Program%20Files/Microsoft%20Office/Office/1033/frontpg.chm::/tab017_select.htm
mk:@MSITStore:C:/Program%20Files/Microsoft%20Office/Office/1033/frontpg.chm::/tab017_select.htm
mk:@MSITStore:C:/Program%20Files/Microsoft%20Office/Office/1033/frontpg.chm::/tab017_select.htm


Microsoft FrontPage 

 

Training Programme under CAFT “Online Content Creation and Management in an eLearning Environment” 

139 

 

Tip   You can also merge cells by clicking Merge Cells on the Tables toolbar. To 

display the Tables toolbar, point to Toolbars on the View menu, and then click Tables. 

3.10 Set the background color in a table 

You can set the background color for a table. You have the option of setting the 

background color for the entire table, for individual cells, or both. When you set 

background colors both for individual cells and the entire table, the cell color will take 

priority. In the example below, both tables have background colors, but the second table 

also has background colors for three cells: 

To set a color for In Page view, do this 

A table background 

Right-click the table, and then click Table Properties on the 

shortcut menu. Under Background, in the Color list, select a color 

for the table background. 

A cell background 

Select the cells, right-click, and then click Cell Properties on the 

shortcut menu. Under Background, in the Color list, select a color 

for the cell background. 

Tip   You can also set a background color for a selected table or group of cells by clicking 

Fill Color on the Tables toolbar. To display the Tables toolbar, point to Toolbars on 

the View menu, and then click Tables.  

3.11 Set the cell layout 

You can set the layout of a cell and its content by changing cell properties.  

1. In Page view, select the cells for which you want to set the layout.  

2. Right-click, and then click Cell Properties on the shortcut menu.  

3. In the Horizontal alignment and Vertical alignment boxes, select the alignment 

you want for the contents of the cell.  

4. To set the cells as header cells and emphasize them, select Header cell. By default, 

the emphasis is bold text.  

5. To prevent Web browsers from wrapping text in the cell, select No wrap.  

3.12 Set the color of table borders 

A table border can be one color or two colors. When you use two colors, the table border 

has a three-dimensional appearance.  

    

    

You can set the border color for the entire table and for individual cell borders. When you 

set border colors both for individual cells and the entire table, the cell color will take 

priority. 

mk:@MSITStore:C:/Program%20Files/Microsoft%20Office/Office/1033/frontpg.chm::/tab017_select.htm
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Note   The border size must be greater than zero; otherwise, the border will not be 

displayed.  

1. In Page view, move the insertion point inside the cell or table for which you want 

to set the border color.  

2. Right-click, and then click Cell Properties or Table Properties, depending on 

whether you want to set a border color for a cell or table.  

3. Do one of the following:  

o To set one color for the border, under Borders, select a color from the 

Color list.  

o To set a two-color border for a three-dimensional effect, under Borders, 

select colors from the Light border and Dark border lists.  

o The color from the Color list will not be used. However, if you select only 

a Light border or a Dark border, the color selected from the Color list 

will be used as the second color.  

o Make sure the border size is greater than zero, otherwise the table border 

will not be displayed.  

3.13 Split cells 

You can divide cells into columns or rows by splitting them.  

      

  

1. In Page view, select the cells to split.  

2. Right-click, and then click Split Cells on the shortcut menu.  

3. Click Split into Columns or Split into Rows.  

4. In the Number of Columns or Number or Rows field, enter the number of 

columns or rows into which you want the cells split.  

Tip   You can also split selected cells by clicking Split Cells on the Tables toolbar. To 

display the Tables toolbar, point to Toolbars on the View menu, and then click Tables 

mk:@MSITStore:C:/Program%20Files/Microsoft%20Office/Office/1033/frontpg.chm::/tab017_select.htm

